Go to footer

Software, Umgang und/oder Probleme damit

Anleitungen / Erklärungen / Beschreibungen

Moderatoren: hansigü, Espresso-Miez, Lenta


Re: Software, Umgang und/oder Probleme damit

Beitragvon padrem » Fr 19. Feb 2021, 13:50

Mikado hat geschrieben:Die alten http Fotoverzeichnisse bestehen lassen,
auf dem https Server neue Fotoverzeichnisse anlegen,
die bisher mit http gespeicherten eigentlichen Fotos physisch in die neuen https Fotoverzeichnisse verschieben,
alte http Fotoverzeichnisse mit einer automatischen Weiterleitung auf die neuen https Fotoverzeichnisse versehen.

Sorry, kannte diese Diskussion bislang nicht. Web-Administration ist zwar nicht mein Tagesgeschäft, sodass ich jetzt nicht der Top-Experte bin, aber das geht bestimmt, was Mika vorschlägt. Einen Apache-Webserver vorausgesetzt, würde man die Weiterleitung über einen 301-Redirect in der .htaccess-Datei realisieren. Das sind zwei Zeilen. Ich kann das ja heute Abend mal zwischen zwei Seiten von mir nachstellen und ausprobieren.

Habe noch kurz stichprobenartig nachgeschaut. Bis ca. 2016 sind wohl die Bilder auf unterschiedlichen Servern untergebracht, die meisten unter https://www.dr-hollensteiner.de - könnte man auch umziehen, muss man aber nicht, die werden dank https ja sowieso angezeigt. Ich würde im ersten Schritt nur http://www.brotbackforum.com/forumimages => https://brotbackforum.iphpbb3.com/forumimages umziehen/weiterleiten. Soweit ich das überblicke, erschlägt das alles bis ca. 2017, dann ist alles ok über https://www.dr-hollensteiner.de, und nur aus der absoluten Anfangszeit scheint es dann noch ein paar Bilder zu geben, die nicht abgedeckt wären.
Grüße, padrem
padrem
 
Beiträge: 233
Registriert: Sa 2. Jan 2021, 11:55


Re: Software, Umgang und/oder Probleme damit

Beitragvon Billa » Fr 19. Feb 2021, 14:24

Albert48 hat geschrieben:Also mich irritiert irgendwie, dass das Problem der nicht angezeigten Bilder offensichtlich kaum jemanden betrifft.


Nun, mich betrifft das Bilderproblem leider auch.
Herzliche Grüße Brigitte
Billa
 
Beiträge: 454
Registriert: Do 2. Sep 2010, 09:44


Re: Software, Umgang und/oder Probleme damit

Beitragvon Caröle » Fr 19. Feb 2021, 15:16

Ich habe gerade mal getestet: Auf meinem Mac kann ich sowohl mit (älterem) Safari und aktuellem Firefox die Bilder sehen, aber sowohl auf dem Mac als auch auf meinem Android-Smartphone sehe ich via Google Chrome keinerlei Bilder.
Caro... mit viel Koch- und langsam auch mehr Backerfahrung :hx

Ausstattung: Kenwood Cooking Chef, Gusseisentopf & -Kastenform, Schamott-Backstein,
nicht so toller Ofen, 2 Sauerteige (Gärhard: Roggen und Gärtrud: Lievito Madre)
Benutzeravatar
Caröle
 
Beiträge: 580
Registriert: Sa 21. Nov 2020, 20:56
Wohnort: Berlin


Re: Software, Umgang und/oder Probleme damit

Beitragvon LieLi » Fr 19. Feb 2021, 18:37

Chrome hat aktuell mit die strengsten Vorgaben, was unsichere Verbindungen angeht.
Deswegen muss man da schon tiefer in den Flags rumbasteln, wenn man das Forum damit nutzen möchte. Einfach nur unsichere Inhalte zulassen reicht hier nicht.
Benutzeravatar
LieLi
 
Beiträge: 507
Registriert: So 1. Mär 2020, 00:46


Re: Software, Umgang und/oder Probleme damit

Beitragvon padrem » Fr 19. Feb 2021, 19:41

_xmas hat geschrieben:Wie vor einiger Zeit beschrieben, würde das einen Serverumzug bedeuten, der im Moment nicht durchführbar ist.

Das mit dem Umzug der alten Bilder ist ja die eine Sache. Was ich aber noch nicht verstanden habe, ist, wo das Problem liegt, dass neu erstellte Bilder auf dem neuen Server (https://brotbackforum.iphpbb3.com) landen. Könnte mir das jemand erklären?

Ansonsten noch ein Hinweis an alle Betroffenen, falls noch nicht bekannt: Es müsste für jeden möglich sein, sich durch Rechtsklick auf das Bildsymbol => "Bild in neuem Tab öffnen" (mag je nach Browser anders heißen) das Bild anzuschauen. Das Blockieren betrifft meines Wissens nur auf HTTPS-Seiten eingebette HTTP-Inhalte (ob es überhaupt eine Einstellungsmöglichkeit gibt, HTTP radikal zu blockieren weiß ich nicht), aber selbstständig kann man sich die Inhalte schon anschauen. Mit Edge und Chrome geht das jedenfalls bei mir, auf meinem Android Handy geht das mit Chrome durch langes Antippen und "Bild öffnen". Natürlich ist das keine akzeptable Lösung auf Dauer, aber taugt vielleicht als vorübergehender Workaround.
Grüße, padrem
padrem
 
Beiträge: 233
Registriert: Sa 2. Jan 2021, 11:55


Re: Software, Umgang und/oder Probleme damit

Beitragvon VolkerC » Fr 19. Feb 2021, 20:46

Hallo,

es ließe sich ohne Serverumzug wie folgt realisieren:

1, Auf dem Bilder Server http://www.brotbackforum.com/ (das ist nicht der Server des Forums) wird ein Zertifikat von LetsEncrypt installiert. Das kostet nichts, muss aber alle 3 Monate verlängert werden.
2. Per .htaccess wird ein automatischer Redirect aller http://www.brotbackforum.com/forumimages auf https://www.brotbackforum.com/forumimages gemacht

Ab dem Zeitpunkt würden alle Forenbilder per https geöffnet und würden Chrome, Edge etc. nicht mehr verborgen bleiben.

Wenn Hilfe gewünscht ist, biete ich mich an.
Herzliche Backgrüße,
Volker
Benutzeravatar
VolkerC
 
Beiträge: 14
Registriert: Mo 25. Jan 2021, 21:56


Re: Software, Umgang und/oder Probleme damit

Beitragvon padrem » Fr 19. Feb 2021, 22:14

Ich ging davon aus, dass es aus irgendwelchen Gründen nicht möglich ist, auf dem Bilder-Server ein SSL-Zertifikat zu installieren. Wenn das geht, ist meiner Meinung nach Volkers Vorschlag die beste da einfachste Lösung. Das sollte schnell gemacht sein.

Den Bilder-Server würde man ja so oder so nicht loswerden können, ohne invasiv vorzugehen, d.h. die ganzen URLs in den Inhalten umzukodieren - und das ist vermutlich nicht gewünscht.

Ob dann zukünftige Bilder auf dem Bilder-Server oder dem Forum-Server liegen sollen/können, ist völlig unabhängig von Volkers Vorschlag.

VolkerC hat geschrieben:Wenn Hilfe gewünscht ist, biete ich mich an.

:top Dann ziehe ich mich quasi wieder zurück aus dem Thema.
Grüße, padrem
padrem
 
Beiträge: 233
Registriert: Sa 2. Jan 2021, 11:55


Re: Software, Umgang und/oder Probleme damit

Beitragvon VolkerC » Sa 20. Feb 2021, 12:14

Hallo padrem,

aber wieso denn zurück ziehen? 4 Augen / 20 Finger an der Tastatur sehen mehr. Selbst wenn der Provider von http://www.brotbackforum.com/forumimages das installieren eines LetsEncrypt Zertifikats verhindern sollte, könnte man immer noch den Provider wechseln und dabei die Domain mit per Redirect oder Umzug mitnehmen. Es gibt auch Provider wie AllInkl.com, die haben das freie LetsEncrypt Zertifikat integriert und verlängern das sogar automatisch für Dich.

Edit:
Hallo,

1und1, HostEurope und Strato bieten beispielsweise keine direkte Unterstützung an für LetsEncrypt an, da müsste man eine manuelle Installation des Zertifikats probieren.
Zuletzt geändert von hansigü am So 21. Feb 2021, 10:08, insgesamt 1-mal geändert.
Grund: zwei aufeinanderfolgende Beiträge zusammengeführt!
Herzliche Backgrüße,
Volker
Benutzeravatar
VolkerC
 
Beiträge: 14
Registriert: Mo 25. Jan 2021, 21:56


Re: Software, Umgang und/oder Probleme damit

Beitragvon padrem » So 21. Feb 2021, 11:41

VolkerC hat geschrieben:aber wieso denn zurück ziehen?

Ich dachte nur, sollte das die Lösung sein - und offensichtlich weißt du, wovon du redest - dann kannst du das schnell erledigen, und die Sache ist geritzt.

Jetzt warten wir erst einmal ab, ob es überhaupt Feedback/Interesse seitens der Administratoren gibt. Ich habe bislang keine Vorstellung, woran was hakt (es heißt ja, ein Serverumzug sei notwendig). So sind wir nur am mutmaßen, und tun können wir sowieso nichts.
Grüße, padrem
padrem
 
Beiträge: 233
Registriert: Sa 2. Jan 2021, 11:55


Re: Software, Umgang und/oder Probleme damit

Beitragvon padrem » Fr 19. Mär 2021, 22:46

Ich fände es schön, wenn es irgendeine Reaktion seitens des/der Verantwortlichen für Web-Administration auf unsere Vorschläge gäbe. Das Problem ist ja für viele User gravierend. Es besteht also Handlungsbedarf. Und ich kann aktuell mangels Hintergrundinformation nicht beurteilen, ob tatsächlich ein unlösbares - bzw. nur durch Serverumzug lösbares - Problem besteht, oder ob es eher an Fachwissen in Sachen Web-Administration mangelt. Wenn Letzteres der Fall ist, wäre es doch schade, die von Usern des Forums offenbar vorhande Expertise nicht zu nutzen. Falls die Problematik schon einmal im Forum fachlich fundiert zu Ende diskutiert wurde, würde ein Verweis auf den entsprechenden Thread ja schon helfen, Licht ins Dunkel zu bringen.
Grüße, padrem
padrem
 
Beiträge: 233
Registriert: Sa 2. Jan 2021, 11:55


Re: Software, Umgang und/oder Probleme damit

Beitragvon Lenta » Sa 20. Mär 2021, 10:07

Hallo padrem,

hinter den Kulissen wird daran gearbeitet, soweit ich es überschauen kann liegt das Problem an mehreren Forumswechseln.
Ich bin da mangels Wissen nicht so sehr involviert.
Vielen Dank für euer Engagement, wenn Ulla eure Hilfe braucht wird sie sich bei euch melden.
Liebe Grüße, Lenta
Benutzeravatar
Lenta
Moderator
Moderator
 
Beiträge: 10395
Registriert: Fr 3. Sep 2010, 15:48
Wohnort: Jenseits der Alpen, manchmal auch jenseits von Gut und Böse


Re: Software, Umgang und/oder Probleme damit

Beitragvon padrem » Sa 20. Mär 2021, 17:53

Hallo Lenta,

vielen Dank für die Info. Super, dann wünsche ich viel Erfolg!
Grüße, padrem
padrem
 
Beiträge: 233
Registriert: Sa 2. Jan 2021, 11:55


Re: Software, Umgang und/oder Probleme damit

Beitragvon Mikado » Sa 20. Mär 2021, 18:13

Lenta hat geschrieben:hinter den Kulissen wird daran gearbeitet,

Es gibt mindestens einen Workaround, der bis jetzt noch nicht umgesetzt wurde...
Beste Grüße
Mika

Gehe nicht, wohin der Weg führen mag, sondern dorthin, wo kein Weg ist, und hinterlasse Spuren. -- Christian Morgenstern
Phantasie ist wichtiger als Wissen, denn Wissen ist begrenzt. -- Albert Einstein
Benutzeravatar
Mikado
 
Beiträge: 2043
Registriert: Do 23. Mär 2017, 16:58
Wohnort: Zwischen den Wassern


Re: Software, Umgang und/oder Probleme damit

Beitragvon _xmas » Sa 20. Mär 2021, 20:05

Sodele meine lieben User. Ein Hinweis von mir, woraus ihr gerne eure Konsequenzen ziehen mögt:

Ich bin beruflich und privat sehr eingespannt und hatte bereits vor einiger Zeit Kontakt mit einem kompetenten Menschen dieses Forums aufgenommen. Leider fehlen mir noch ein paar Informationen, die ich angefragt und auf die ich noch keine Antwort erhalten habe. Über weitere Hintergründe werde ich keine Auskünfte geben.

Die Teilnahme der Nutzer dieses Forums ist freiwillig, meine Arbeit und der damit verbundene finanzielle und zeitliche Aufwand ebenfalls.

Ich bin sehr daran interessiert, dass eine zufriedenstellende Lösung gefunden wird. Dazu brauche ich kompetente Unterstützung und fachlichen Rat von außen. Aber die Problematik hier zu diskutieren, wird keine Lösung bringen und ist nicht erwünscht.

Allen Usern, die damir nicht klar kommen empfehle ich, das Forum zu verlassen oder vorerst mit den aktuellen Gegebenheiten zu leben.
Alle sagten: das geht nicht.
Dann kam einer, der wusste das nicht, und hat´s einfach gemacht.
Benutzeravatar
_xmas
Administrator
Administrator
 
Beiträge: 12638
Registriert: Di 8. Mär 2011, 23:05
Wohnort: tief im Westen


Re: Software, Umgang und/oder Probleme damit

Beitragvon BrotRookie » Mo 22. Mär 2021, 15:53

Moin,

angeregt durch die Diskussion hier habe ich versucht, in meinem aktuellen Browser (Vivaldi, Vers. 3.7.2218.45) die Bilderanzeige hinzukriegen. Bisher hatte ich nämlich auch nur ein kleines Icon mit der "Bild" Beschriftung, so dass ich auf den Firefox (vers. 86.0.1) gewechselt bin für dieses Forum (das Auge isst ja bekanntlich mit 8-)

Nachdem ich im Vivaldi unter Einstellungen -> Datenschutz und Sicherheit (*: siehe Nachtrag) die Optionen "Unsichere Inhalte" und "Bilder" explizit auf "Erlauben" eingestellt hatte, wurde nach einem Neuladen der Forenseiten mit Bildern diese auch angezeigt. Was für den Vivaldi gilt, könnte auch für den Chromium Browser gelten. Ob auch für den Chrome (von Google/Alphabet Inc.), kann ich aber nicht sagen.

Vielleicht hilft es ja dem ein oder der anderen.

Gruß
Thomas

Nachtrag: In diesen Einstellungsbereich kommt man, wenn man auf das kleine Icon in der Adresszeile klickt (also da wo ...ps://brotbackforum.iphpbb3.com/ ... steht), dann in dem Aufklapp-Menü die Option "Website-Einstellungen".
Ich backe, also bin ich.
BrotRookie
 
Beiträge: 127
Registriert: So 4. Feb 2018, 00:51


Re: Software, Umgang und/oder Probleme damit

Beitragvon Mugerli » Mo 22. Mär 2021, 16:34

BrotRookie hat geschrieben:Ob auch für den Chrome (von Google/Alphabet Inc.), kann ich aber nicht sagen.

Bei Chrome funktioniert es auch - jetzt kann ich das Forum wenigstens auch am PC nutzen :kl

Danke dir für den explizitem Hinweis auf "https://brotbackforum.iphpbb3.com/" :idea:
Ich hatte bislang wohl nur versucht, die unsicheren Inhalte von "http://www.brotbackforum.com/" anzeigen zu lassen :? (weil dort die Bilder liegen), was nicht den erhofften Erfolg brachte :roll: . Aber dort braucht man an den Einstellungen nichts zu ändern.

Gerade noch Edge getestet: hier jetzt auch mit Bildern :cha (via "Websiteberechtigungen" einstellbar).

Nur beim aktuellen Firefox komme ich nach wie vor nicht weiter :lala .
Benutzeravatar
Mugerli
 
Beiträge: 210
Registriert: Fr 29. Jan 2021, 16:57
Wohnort: Schweiz


Re: Software, Umgang und/oder Probleme damit

Beitragvon matthes » So 28. Mär 2021, 07:41

Guten Morgen,

ich poste das mal hier:

Durch die Umstellung heute Nacht auf Sommerzeit, dran denken, hier auf "Ja" setzen ;)

Bild
Das bin ich (Matthias)
Benutzeravatar
matthes
 
Beiträge: 730
Registriert: Sa 30. Jan 2021, 09:35


Re: Software, Umgang und/oder Probleme damit

Beitragvon UlliD » So 28. Mär 2021, 09:09

Danke Matthias, hätt ich garantiert verpennt.... :top
Liebe Grüße vom Ulli aus Forst
Benutzeravatar
UlliD
 
Beiträge: 1018
Registriert: Sa 5. Jan 2019, 17:52
Wohnort: Forst/Lausitz


Re: Software, Umgang und/oder Probleme damit

Beitragvon VolkerC » Di 30. Mär 2021, 23:58

Hallo,

kann mir mal bitte jemand mit Chrome oder Edge sagen, ob die Bilder jetzt alle wieder für Euch zu sehen sind? Ich habe nur den Feuerfuchs am Start und kann es nicht selbst testen, denn der zeigt sie ja alle.
Herzliche Backgrüße,
Volker
Benutzeravatar
VolkerC
 
Beiträge: 14
Registriert: Mo 25. Jan 2021, 21:56


Re: Software, Umgang und/oder Probleme damit

Beitragvon matthes » Mi 31. Mär 2021, 05:52

Hallo Volker,

für beide Browser ein :top
Das bin ich (Matthias)
Benutzeravatar
matthes
 
Beiträge: 730
Registriert: Sa 30. Jan 2021, 09:35

VorherigeNächste


Ähnliche Beiträge

Enttäusch über Assistent. Wie Richtigen Umgang lernen?
Forum: Küchenmaschinen
Autor: Flowerking
Antworten: 37
Probleme mit Kenwood Titanium
Forum: Küchenmaschinen
Autor: Catwoman2
Antworten: 12
Vinjett Weizen - hat jemand Erfahrung damit?
Forum: Mehle, Getreide, Saaten und Körner
Autor: nr15
Antworten: 7
Umgang mit Back-Hefe
Forum: Anfängerfragen
Autor: Backong
Antworten: 1
Probleme mit Nusstorte
Forum: Anfängerfragen
Autor: torb
Antworten: 10

Zurück zu Foren-Übersicht

Zurück zu Tutorien

Wer ist online?

0 Mitglieder





Hosted by iphpbb3.com
Beliebteste Themen: Rezept, Liebe, USA

Impressum | Datenschutz